hallux4

Readiness Check fail

Recommended Posts

Hi,

I can't seem to find any related post on the web addressing this issue.

I am new to magento (installed today for the first time) and I did nothing except install this tool, but maybe I forgot some step to begin with.

I cannot open a shop without a working Ebay integration :( 

______________

Error! You need to resolve these issues to continue.

Check Component Dependency

We found conflicting component dependencies. Hide detail

Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for magento/product-community-edition 2.1.0 -> satisfiable by magento/product-community-edition[2.1.0].
- m2epro/ebay-amazon-rakuten-sears-magento-integration-order-import-and-stock-level-synchronization 1.0.0 requires magento/module-catalog 100.* -> satisfiable by magento/module-catalog[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9].
- Can only install one of: magento/module-catalog[101.0.0, 100.0.2].
- Can only install one of: magento/module-catalog[101.0.0, 100.0.3].
- Can only install one of: magento/module-catalog[101.0.0, 100.0.4].
- Can only install one of: magento/module-catalog[101.0.0, 100.0.5].
- Can only install one of: magento/module-catalog[101.0.0, 100.0.6].
- Can only install one of: magento/module-catalog[101.0.0, 100.0.7].
- Can only install one of: magento/module-catalog[101.0.0, 100.0.8].
- Can only install one of: magento/module-catalog[101.0.0, 100.0.9].
- magento/product-community-edition 2.1.0 requires magento/module-catalog 101.0.0 -> satisfiable by magento/module-catalog[101.0.0].
- Installation request for m2epro/ebay-amazon-rakuten-sears-magento-integration-order-import-and-stock-level-synchronization 1.0.0 -> satisfiable by m2epro/ebay-amazon-rakuten-sears-magento-integration-order-import-and-stock-level-synchronization[1.0.0].

Regards

m2e_pro.PNG

Share this post


Link to post
Share on other sites

Its the 10th and I am still having issues with it but the error is different.

 

Problem 1
- The requested package m2epro/ebay-amazon-rakuten-sears-magento-integration-order-import-and-stock-level-synchronization could not be found in any version, there may be a typo in the package name.

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Screen Shot 2016-09-10 at 12.41.08 PM.png

Share this post


Link to post
Share on other sites

Ok so I just had to fork it and modify the composer.json and submit it myself then install it through the command line. I finally got it installed.

do this... just keep in mind if you don't have php70 don't use that just use php instead. The GUI installer is garbage.

1. 

composer require m2epro/ebay-amazon-rakuten-sears-magento-integration-order-import-and-stock-level-synchronization

2.

php70 -f bin/magento setup:upgrade

3. 

sudo php70 bin/magento setup:di:compile

4.

sudo php70 bin/magento deploy:mode:set production

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.