Westwood

How to configure your image gallery not to have an “onclick” event

Recommended Posts

Can anyone advise on how to configure your image gallery not to have an “onclick” event please?

We changed our listing template to conform with the non-active content rule, but it is not showing as 'mobile friendly' on the i-ways tool.

Apparently, it is an M2epro issue. And need to know how to configure the gallery.

I've looked on knowledgebase, can't find anything. Can anyone help please?

 

Thanks

Share this post


Link to post
Share on other sites

Yes, curious about this too. considering ebay's shortly upcoming Active Content policy changes.  

It seems that the current M2e Media Gallery function as it stands will not work when 'Previewing' the Active Content switch on the ebay listing.

So for example, of course, in our current listing template, we have:   #media_gallery[800,800,0,2,column,0,"",]#    -- but unfortunately it will appear to be non-functional after the upcoming changes

Is there any other method to still use M2e's built-in image Gallery and ensure ebay Active Content compatibility/functionality?

 

I have noticed this here for Magento "2.0" however (I'm only planning on sticking with Magento ver. 1 family for the foreseeable future), but unfortunately could not find this same update/upgrade function for Magento 1's version of M2e.  There is apparently a CSS replacement to the previous Javascript-based Gallery function.  It would be great if this could also work for ver 1 (perhaps it's a limitation of Magento 1 + M2e):

ql39rc.jpg

Edited by jwtsb007

Share this post


Link to post
Share on other sites

Hey guys, check these release notes out.  I just had missed them.   It seems if you simply update M2e for Magento 1 to its latest version, it should then now have the CSS replacement for the old Javascript-based Image Gallery functionality.   Sweet.   Doing that right now as we speak!
  

 

  • Upvote 1

Share this post


Link to post
Share on other sites

After 4 days I had a response from support, unfortunately it was useless. Basically saying M2E has supported CSS for image galleries since 6.4.9 and so the issue is within my description. It isn't. 

They ignored the issue with the red Magento debug boxes.

I have asked them to "reconsider" their reply.

Share this post


Link to post
Share on other sites

Still no sensible reply and I've given up.

Have now had 2 replies that included links telling me how to enable / disable template hints in Magento, I am aware of how to do this, I have no hints ANYWHERE other than on the image panel within my Ebay listings.

Support = totally and utterly useless. 

Anyone else able to help, please?

 

Share this post


Link to post
Share on other sites

@NickT dirty CSS solution:
 

div#gallery > div#etb-gallery > div {
    border: none !important;
}
div#gallery > div#etb-gallery > div > div {
    background: none !important;
}

 

Edited by manolinda

Share this post


Link to post
Share on other sites
On 12.06.2017 at 6:25 PM, NickT said:

Still no sensible reply and I've given up.

Have now had 2 replies that included links telling me how to enable / disable template hints in Magento, I am aware of how to do this, I have no hints ANYWHERE other than on the image panel within my Ebay listings.

Support = totally and utterly useless. 

Anyone else able to help, please?

 

Nick, the debug boxes may indeed result from the enabled template hints in your Magento. It might be a reasonable suggestion to check the configurations in your Magento. 
The version 6.4.10 that M2E released in May processes the gallery through pure CSS. We did some tests too, it goes pretty smooth. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.