Ray Z

Qty Sync Issue

Recommended Posts

After a week testing, I have found that the qty will not be syncing if the qty changes from In Stock (<1) to Out of Stock (0). It syncs with no issue if the stock status is in stock. The problem happens when QTY gets out of stock status it stops syncing.

Please advise me.

Ray

Share this post


Link to post
Share on other sites

Can you please be more specific with your problem Ray. When you say OUT OF STOCK etc, are you talking about magento or ebay status. please re-write your issue in more detail.

Thanks,

Mat

Share this post


Link to post
Share on other sites

Hi,
Did you ever manage to find a solution to this as I am having the same problem.

Just to clarity;
The product is in stock with a quantity of 1 and listed on eBay. 
The product sells on eBay.

Expected result: 
Order added in Magento
Quantity reduced to 0
Status set to Out of stock

Actual Result:
Order fails to be added in Magento (error: Product that you are trying to add is not available.)
Quantity is left at 1
Status set to Out of stock

Any suggestions appreciated.

Cheers,

Olly

Share this post


Link to post
Share on other sites

Have the same issue exactly how Oliver reported.  I'm also having it create an order as pending.  We're having to cancel that order, set to in stock and verify QTY then click the "create magento order" button and go back and fix/check the QTY again.  

I did notice our items we imported from 3rd party do not have this issue and seem to be working properly from our testing.

Share this post


Link to post
Share on other sites

Thanks for replying. I'm kind of glad i'm not the only one with this issue.

For reference, I also have the orders set as pending.

I haven't tested 3rd party products so can't say if that bit is working for me.

Have you had any help from the M2E support?
I've tried for ages but not got anywhere. 
Last I heard was over a couple of weeks back saying it was being escalated.

I should really look for an alternative extension just haven't had time.

I'd be grateful if you could keep me updated on any progress you make.

Cheers

Share this post


Link to post
Share on other sites

We just switched from Wordpress to Magento.  Their plugin was great and worked perfectly, but we're growing and need something more enterprise and support for other marketplaces.   We've been a mess and tried about 5-10 other products and finally decided on Magento because we can build in the features that's missing.  Hopefully they get this fixed soon or we'll have to find something else.   We'll keep this updated if we hear anything.  

Share this post


Link to post
Share on other sites

Hi Guys

Having been racking my brains trying to work out what I have not done correctly in order for my qts to not sync correctly, the issue I have is exactly the same as Olivers. Everytime a product gets down to the last 1 it doesn't seem to create the order in magento. I have to manually update the qty to 2 in magento admin and set back to instock then create order manually in m2e pro which will then create the order. Also I have to then change the qty back to 0 in magento admin.

I am running magento 2.2.1

m2e pro version 1.3.2

m2e pro upgrade module 1.4.2

Share this post


Link to post
Share on other sites

Sorry to hear that you're having the same problem but hopefully now there are a few of us the developers might get involved.
I've pretty much given up with the support tickets, just a waste of time.

Have any of you looked into Webkul or channelunity ?
I will do some investigation when I get time but having only just moved to Magento from Woocommerce, my todo list is pretty big still.

Share this post


Link to post
Share on other sites

Thank you all for providing information about this issue.

For the last several months we have had the same issue where by an order is received from m2e pro - amazon or ebay and the product status has gone to out of stock in our magento catalogue. However even though on amazon or ebay the product quantity is 0, in our magento catalogue the product quantity remains the same but with out of stock status.

I have messaged m2e pro several times about this, to the extent we even turned off all our other 3rd party modules as they were saying that this issue is related to ancillary services of our magento installation but we still have the same issue. 

I have come across this forum and now I have messaged them inquiring about this patch that was applied to for gman86. 

Regards,

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.