Marcus

Finding "System > Configuration > M2E Pro > Advanced" in Magento v1.x

Recommended Posts

I'm in the middle of a Magento 1.x -> 2.x migration.

Migrating M2pro is the only step that could not be tested in advance because it can only be done once and not rolled back.

Now the mirgation wizard tells me:

"Dynamic functioning of M2E Pro has to be disabled for both Magento v1.x and Magento v2.x.

To do that, you should navigate to System > Configuration > M2E Pro > Advanced in your Magento v1.x and click Proceed button."

 

However (after switching to English, so I don't have to guess translations) there is only
System > Configuration > M2E Pro > Channels
System > Configuration > M2E Pro > General
System > Configuration > M2E Pro > Log Clearing
System > Configuration > M2E Pro > License

not one of them has a "proceed" button.
There is no option named "dynamic functioning".

 

Can anyone tell me where to find that "proceed" button?

The installed version on Magento 1.x is the special "6.4.14 (stable)"  that is needed for the migration.

PS:

To reach that menu I need to remove the maintenance.flag -file every time, thus also opening up the old shop for customers while not being supposed to touch it at all.

Share this post


Link to post
Share on other sites

My mistake.

With too much coffee and too little sleep in this giant migration I saw that the upload of the 6.5 module had failed again.

(Provided link was for a zip file for brute force "installation" via ftp and not the "connect2" variant of the file to install via connect manager upload.)

 

PS:

I am getting some

main.CRITICAL: SQLSTATE[42S02]: Base table or view not found: 1146 Table '<DBNAME>.m2epro_module_config' doesn't exist, query was: SELECT COUNT(*) FROM `m2epro_module_config` AS `main_table` [] []

in the logs. Hopefully it still works.

Edited by Marcus

Share this post


Link to post
Share on other sites

I tried creating the missing table with the information from

vendor/m2e/ebay-amazon-magento2/Setup/InstallSchema.php

but Mysql does not want me to create columns named "key" and "group" since these are reserved keywords.

(even when escaped with ` backticks)

Share this post


Link to post
Share on other sites

It seems to be normal that the  system is 99% idle and no new log entries apear for 15+ minutes during the migration.

Edited by Marcus

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.